$re = '/(?!vk\.com)[a-z0-9\-\_]{2,64}\.[a-z]{2,6}/';
$str = 'zzz.com
aaa.net
vk.com
blabla.bla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);