package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(es-[a-z]+)\/`)
var str = `/es-es/Replica-2300/saliffanag/winsrow
/es-de/Bat-00/saliffanag/winsrow
/es-it/Re-2300/saliffanag/winsrow
/es-../`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}