re = /\/(es-[a-z]+)\//m
str = '/es-es/Replica-2300/saliffanag/winsrow
/es-de/Bat-00/saliffanag/winsrow
/es-it/Re-2300/saliffanag/winsrow
/es-../'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end