using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s=]+)=([\w\W]*?)(?=\s+[^\s=]+=|$)";
string input = @"a=1 b=2 c=1
and
2 d=3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}