$re = '/([^\s=]+)=([\w\W]*?)(?=\s+[^\s=]+=|$)/';
$str = 'a=1 b=2 c=1
and
2 d=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);