import re
regex = re.compile(r"^([0-3]($|\.)|4.(0|[0-9]($|\.))|4\.10\.190[0-3])", flags=re.MULTILINE)
test_str = ("4.10.19041401\n"
"4.10.190\n"
"4.9\n"
"4.0.\n"
"4.9.\n"
"3\n"
"3.\n"
"30\n\n"
" \n"
"^([0-3]|4.(0|([0-9]\\.))|4\\.10\\.190[0-3])\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")