#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[!-,.-/:-@[-`{-~]"
Local $sString = "! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ \ { | } ~" & @CRLF & _
"32 040 20 00100000   Space" & @CRLF & _
"33 041 21 00100001 ! ! Exclamation mark" & @CRLF & _
"34 042 22 00100010 " " " Double quotes (or speech marks)" & @CRLF & _
"35 043 23 00100011 # # Number" & @CRLF & _
"36 044 24 00100100 $ $ Dollar" & @CRLF & _
"37 045 25 00100101 % % Procenttecken" & @CRLF & _
"38 046 26 00100110 & & & Ampersand" & @CRLF & _
"39 047 27 00100111 ' ' Single quote" & @CRLF & _
"40 050 28 00101000 ( ( Open parenthesis (or open bracket)" & @CRLF & _
"41 051 29 00101001 ) ) Close parenthesis (or close bracket)" & @CRLF & _
"42 052 2A 00101010 * * Asterisk" & @CRLF & _
"43 053 2B 00101011 + + Plus" & @CRLF & _
"44 054 2C 00101100 , , Comma" & @CRLF & _
"45 055 2D 00101101 - - Hyphen" & @CRLF & _
"46 056 2E 00101110 . . Period, dot or full stop" & @CRLF & _
"47 057 2F 00101111 / / Slash or divide" & @CRLF & _
"48 060 30 00110000 0 0 Zero" & @CRLF & _
"49 061 31 00110001 1 1 One" & @CRLF & _
"50 062 32 00110010 2 2 Two" & @CRLF & _
"51 063 33 00110011 3 3 Three" & @CRLF & _
"52 064 34 00110100 4 4 Four" & @CRLF & _
"53 065 35 00110101 5 5 Five" & @CRLF & _
"54 066 36 00110110 6 6 Six" & @CRLF & _
"55 067 37 00110111 7 7 Seven" & @CRLF & _
"56 070 38 00111000 8 8 Eight" & @CRLF & _
"57 071 39 00111001 9 9 Nine" & @CRLF & _
"58 072 3A 00111010 : : Colon" & @CRLF & _
"59 073 3B 00111011 ; ; Semicolon" & @CRLF & _
"60 074 3C 00111100 < < < Less than (or open angled bracket)" & @CRLF & _
"61 075 3D 00111101 = = Equals" & @CRLF & _
"62 076 3E 00111110 > > > Greater than (or close angled bracket)" & @CRLF & _
"63 077 3F 00111111 ? ? Question mark" & @CRLF & _
"64 100 40 01000000 @ @ At symbol" & @CRLF & _
"65 101 41 01000001 A A Uppercase A" & @CRLF & _
"66 102 42 01000010 B B Uppercase B" & @CRLF & _
"67 103 43 01000011 C C Uppercase C" & @CRLF & _
"68 104 44 01000100 D D Uppercase D" & @CRLF & _
"69 105 45 01000101 E E Uppercase E" & @CRLF & _
"70 106 46 01000110 F F Uppercase F" & @CRLF & _
"71 107 47 01000111 G G Uppercase G" & @CRLF & _
"72 110 48 01001000 H H Uppercase H" & @CRLF & _
"73 111 49 01001001 I I Uppercase I" & @CRLF & _
"74 112 4A 01001010 J J Uppercase J" & @CRLF & _
"75 113 4B 01001011 K K Uppercase K" & @CRLF & _
"76 114 4C 01001100 L L Uppercase L" & @CRLF & _
"77 115 4D 01001101 M M Uppercase M" & @CRLF & _
"78 116 4E 01001110 N N Uppercase N" & @CRLF & _
"79 117 4F 01001111 O O Uppercase O" & @CRLF & _
"80 120 50 01010000 P P Uppercase P" & @CRLF & _
"81 121 51 01010001 Q Q Uppercase Q" & @CRLF & _
"82 122 52 01010010 R R Uppercase R" & @CRLF & _
"83 123 53 01010011 S S Uppercase S" & @CRLF & _
"84 124 54 01010100 T T Uppercase T" & @CRLF & _
"85 125 55 01010101 U U Uppercase U" & @CRLF & _
"86 126 56 01010110 V V Uppercase V" & @CRLF & _
"87 127 57 01010111 W W Uppercase W" & @CRLF & _
"88 130 58 01011000 X X Uppercase X" & @CRLF & _
"89 131 59 01011001 Y Y Uppercase Y" & @CRLF & _
"90 132 5A 01011010 Z Z Uppercase Z" & @CRLF & _
"91 133 5B 01011011 [ [ Opening bracket" & @CRLF & _
"92 134 5C 01011100 \ \ Backslash" & @CRLF & _
"93 135 5D 01011101 ] ] Closing bracket" & @CRLF & _
"94 136 5E 01011110 ^ ^ Caret - circumflex" & @CRLF & _
"95 137 5F 01011111 _ _ Underscore" & @CRLF & _
"96 140 60 01100000 ` ` Grave accent" & @CRLF & _
"97 141 61 01100001 a a Lowercase a" & @CRLF & _
"98 142 62 01100010 b b Lowercase b" & @CRLF & _
"99 143 63 01100011 c c Lowercase c" & @CRLF & _
"100 144 64 01100100 d d Lowercase d" & @CRLF & _
"101 145 65 01100101 e e Lowercase e" & @CRLF & _
"102 146 66 01100110 f f Lowercase f" & @CRLF & _
"103 147 67 01100111 g g Lowercase g" & @CRLF & _
"104 150 68 01101000 h h Lowercase h" & @CRLF & _
"105 151 69 01101001 i i Lowercase i" & @CRLF & _
"106 152 6A 01101010 j j Lowercase j" & @CRLF & _
"107 153 6B 01101011 k k Lowercase k" & @CRLF & _
"108 154 6C 01101100 l l Lowercase l" & @CRLF & _
"109 155 6D 01101101 m m Lowercase m" & @CRLF & _
"110 156 6E 01101110 n n Lowercase n" & @CRLF & _
"111 157 6F 01101111 o o Lowercase o" & @CRLF & _
"112 160 70 01110000 p p Lowercase p" & @CRLF & _
"113 161 71 01110001 q q Lowercase q" & @CRLF & _
"114 162 72 01110010 r r Lowercase r" & @CRLF & _
"115 163 73 01110011 s s Lowercase s" & @CRLF & _
"116 164 74 01110100 t t Lowercase t" & @CRLF & _
"117 165 75 01110101 u u Lowercase u" & @CRLF & _
"118 166 76 01110110 v v Lowercase v" & @CRLF & _
"119 167 77 01110111 w w Lowercase w" & @CRLF & _
"120 170 78 01111000 x x Lowercase x" & @CRLF & _
"121 171 79 01111001 y y Lowercase y" & @CRLF & _
"122 172 7A 01111010 z z Lowercase z" & @CRLF & _
"123 173 7B 01111011 { { Opening brace" & @CRLF & _
"124 174 7C 01111100 | | Vertical bar" & @CRLF & _
"125 175 7D 01111101 } } Closing brace" & @CRLF & _
"126 176 7E 01111110 ~ ~ Equivalency sign - tilde" & @CRLF & _
"127 177 7F 01111111  Delete"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")