# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[!-,.-/:-@[-`{-~]"
test_str = ("! \" # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \\ ] ^ _ \\ { | } ~\n"
"32 040 20 00100000   Space\n"
"33 041 21 00100001 ! ! Exclamation mark\n"
"34 042 22 00100010 \" " " Double quotes (or speech marks)\n"
"35 043 23 00100011 # # Number\n"
"36 044 24 00100100 $ $ Dollar\n"
"37 045 25 00100101 % % Procenttecken\n"
"38 046 26 00100110 & & & Ampersand\n"
"39 047 27 00100111 ' ' Single quote\n"
"40 050 28 00101000 ( ( Open parenthesis (or open bracket)\n"
"41 051 29 00101001 ) ) Close parenthesis (or close bracket)\n"
"42 052 2A 00101010 * * Asterisk\n"
"43 053 2B 00101011 + + Plus\n"
"44 054 2C 00101100 , , Comma\n"
"45 055 2D 00101101 - - Hyphen\n"
"46 056 2E 00101110 . . Period, dot or full stop\n"
"47 057 2F 00101111 / / Slash or divide\n"
"48 060 30 00110000 0 0 Zero\n"
"49 061 31 00110001 1 1 One\n"
"50 062 32 00110010 2 2 Two\n"
"51 063 33 00110011 3 3 Three\n"
"52 064 34 00110100 4 4 Four\n"
"53 065 35 00110101 5 5 Five\n"
"54 066 36 00110110 6 6 Six\n"
"55 067 37 00110111 7 7 Seven\n"
"56 070 38 00111000 8 8 Eight\n"
"57 071 39 00111001 9 9 Nine\n"
"58 072 3A 00111010 : : Colon\n"
"59 073 3B 00111011 ; ; Semicolon\n"
"60 074 3C 00111100 < < < Less than (or open angled bracket)\n"
"61 075 3D 00111101 = = Equals\n"
"62 076 3E 00111110 > > > Greater than (or close angled bracket)\n"
"63 077 3F 00111111 ? ? Question mark\n"
"64 100 40 01000000 @ @ At symbol\n"
"65 101 41 01000001 A A Uppercase A\n"
"66 102 42 01000010 B B Uppercase B\n"
"67 103 43 01000011 C C Uppercase C\n"
"68 104 44 01000100 D D Uppercase D\n"
"69 105 45 01000101 E E Uppercase E\n"
"70 106 46 01000110 F F Uppercase F\n"
"71 107 47 01000111 G G Uppercase G\n"
"72 110 48 01001000 H H Uppercase H\n"
"73 111 49 01001001 I I Uppercase I\n"
"74 112 4A 01001010 J J Uppercase J\n"
"75 113 4B 01001011 K K Uppercase K\n"
"76 114 4C 01001100 L L Uppercase L\n"
"77 115 4D 01001101 M M Uppercase M\n"
"78 116 4E 01001110 N N Uppercase N\n"
"79 117 4F 01001111 O O Uppercase O\n"
"80 120 50 01010000 P P Uppercase P\n"
"81 121 51 01010001 Q Q Uppercase Q\n"
"82 122 52 01010010 R R Uppercase R\n"
"83 123 53 01010011 S S Uppercase S\n"
"84 124 54 01010100 T T Uppercase T\n"
"85 125 55 01010101 U U Uppercase U\n"
"86 126 56 01010110 V V Uppercase V\n"
"87 127 57 01010111 W W Uppercase W\n"
"88 130 58 01011000 X X Uppercase X\n"
"89 131 59 01011001 Y Y Uppercase Y\n"
"90 132 5A 01011010 Z Z Uppercase Z\n"
"91 133 5B 01011011 [ [ Opening bracket\n"
"92 134 5C 01011100 \\ \ Backslash\n"
"93 135 5D 01011101 ] ] Closing bracket\n"
"94 136 5E 01011110 ^ ^ Caret - circumflex\n"
"95 137 5F 01011111 _ _ Underscore\n"
"96 140 60 01100000 ` ` Grave accent\n"
"97 141 61 01100001 a a Lowercase a\n"
"98 142 62 01100010 b b Lowercase b\n"
"99 143 63 01100011 c c Lowercase c\n"
"100 144 64 01100100 d d Lowercase d\n"
"101 145 65 01100101 e e Lowercase e\n"
"102 146 66 01100110 f f Lowercase f\n"
"103 147 67 01100111 g g Lowercase g\n"
"104 150 68 01101000 h h Lowercase h\n"
"105 151 69 01101001 i i Lowercase i\n"
"106 152 6A 01101010 j j Lowercase j\n"
"107 153 6B 01101011 k k Lowercase k\n"
"108 154 6C 01101100 l l Lowercase l\n"
"109 155 6D 01101101 m m Lowercase m\n"
"110 156 6E 01101110 n n Lowercase n\n"
"111 157 6F 01101111 o o Lowercase o\n"
"112 160 70 01110000 p p Lowercase p\n"
"113 161 71 01110001 q q Lowercase q\n"
"114 162 72 01110010 r r Lowercase r\n"
"115 163 73 01110011 s s Lowercase s\n"
"116 164 74 01110100 t t Lowercase t\n"
"117 165 75 01110101 u u Lowercase u\n"
"118 166 76 01110110 v v Lowercase v\n"
"119 167 77 01110111 w w Lowercase w\n"
"120 170 78 01111000 x x Lowercase x\n"
"121 171 79 01111001 y y Lowercase y\n"
"122 172 7A 01111010 z z Lowercase z\n"
"123 173 7B 01111011 { { Opening brace\n"
"124 174 7C 01111100 | | Vertical bar\n"
"125 175 7D 01111101 } } Closing brace\n"
"126 176 7E 01111110 ~ ~ Equivalency sign - tilde\n"
"127 177 7F 01111111  Delete")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.