using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"t[aeiouy]t[aeiouy]";
string input = @"toto
titi
tutu
trtu";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}