package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)t[aeiouy]t[aeiouy]`)
var str = `toto
titi
tutu
trtu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}