import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?<!\\A)\\||(?:\\[x]\\s[?!]?\\s*\\|?))\\K([^|\\n]*)";
final String string = "\n"
+ "- [x] Example of a completed task.\n"
+ "- [x] ! Example of a completed task.\n"
+ "- [x] ? Example of a completed task.\n\n"
+ "| | Task name | Plan | Actual | File |\n"
+ "| :---- | :-------------------------------------- | :---------: | :---------: | :------------: |\n"
+ "| [x] | Task one with a reasonably long name. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
+ "| [x] ! | Task two with a reasonably long name. | 09:00-09:30 | | [[task-two]] |\n"
+ "| [x] ? | Task three with a reasonably long name. | 11:00-13:00 | | [[task-three]] |\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}