# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\G(?<!\A)\||(?:\[x]\s[?!]?\s*\|?))\K([^|\n]*)"
test_str = ("\n"
"- [x] Example of a completed task.\n"
"- [x] ! Example of a completed task.\n"
"- [x] ? Example of a completed task.\n\n"
"| | Task name | Plan | Actual | File |\n"
"| :---- | :-------------------------------------- | :---------: | :---------: | :------------: |\n"
"| [x] | Task one with a reasonably long name. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
"| [x] ! | Task two with a reasonably long name. | 09:00-09:30 | | [[task-two]] |\n"
"| [x] ? | Task three with a reasonably long name. | 11:00-13:00 | | [[task-three]] |\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.