$re = '/^(?:test|!!)\s.*(*SKIP)(*FAIL)|(?<=Street|,)(?=\d)/m';
$str = 'Street1-2,4,6,8-10
!! Street4/31/2
test Street4';
$subst = "UK/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;