#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?(DEFINE)(?'word'(?:[a-zA-Z0-9!?'"&\.,+@%~$]|(?<! )-(?! ))+)(?'words'(?&word)(?: (?&word))*?)(?'nothe'(?<!, (?i:a))(?<!, (?i:the|les)))(?'ver_prefix'Rev|Proto|Alpha|Beta))(?'title'(?&words)(?¬he))(?'subtitle' - (?&words))*?(?'upd' (?:Update|DLC - (?&words)))?(?'region' \((?:(?:A|As|B|C|Ch|Nl|E|F|G|Gr|Hk|I|J|K|No|R|S|Sw|U|Uk|Tw|W))+\))?(?'version' \[(?:(?:(?&ver_prefix) )?(?:(?'_ver'[\da-zA-Z]+)(?:\.(?&_ver))+|\d\d\d\d-\d\d(?:-\d\d(?:T\d+)?)?)|(?&ver_prefix)( (?:[A-Z]|\d+|early))?)\])?(?'part' \(Dis(?:c|k) \d+\))?(?'language' \((?'_lang'(?:F-)?(?:Ja|En|Fr|De|Es|It|Nl|Ca|Fi|No|Sv|Da|Zh(?:-Hant|-Hans)?|Pt|Ru|Ko|Pl))(?:,?(?&_lang))*\))?(?'randomshit'(?: \[DEMO\])?(?'lossy' \[LOSSY\])?(?: \[Sample\])?(?: \(Promo\))?(?: \(Unl\))?)(?'features' \[(?'_feat'[a-zA-Z]+)(?:, ?(?&_feat))*\])?(?'ext'\.(?:gbc|gb|nsp|xci|(nkit\.)?rvz|gcz|wbfs|wad|gba|type|cia|3ds|nds|nes|sfc|smc|n64|z64|wux|gg|md|sms|iso|pce|chd))$"
Local $sString = "Amazing Spider Man (UE).gb" & @CRLF & _
"Otto's Ottifanten - Baby Bruno's Nightmare (E) (En,Fr,De,Es).gb" & @CRLF & _
"Pokemon Kristall (G).gbc" & @CRLF & _
"A Hat in Time DLC - Nyakuza Metro [1.1.0].nsp" & @CRLF & _
"Pokemon Card GB2 - GR Dan Sanjou! (J).gbc" & @CRLF & _
"Asphalt 9 Legends [1.3.1].nsp" & @CRLF & _
"Animal Crossing New Horizons DLC - Special Order Ticket Pocket Camp tie-in campaign.nsp" & @CRLF & _
"Pokemon Pinball (E) (En,Fr,De,Es,It) [S,DMG].gbc" & @CRLF & _
"Arcade Hits - Moon Patrol & Spy Hunter (UE) [DMG].gbc" & @CRLF & _
"Daikatana (U) [Proto 2000-04-19] [DMG].gbc" & @CRLF & _
"Hang Time Basketball (E) (Unl).gbc" & @CRLF & _
"Pokemon Green (J) [1.0] (F-En).gb" & @CRLF & _
"LSDJ [9.2.L].gb" & @CRLF & _
"Keep Talking and Nobody Explodes Update [1.2.0].nsp" & @CRLF & _
"Sonic Mania Plus [1.0.4] (En,Ja,Fr,De,Es,It,Zh).xci" & @CRLF & _
"Spelunky [1.22.2a].nsp" & @CRLF & _
"Chrono Cross (U) (Disc 1).chd" & @CRLF & _
"Chrono Cross (U) (Disc 2).chd" & @CRLF & _
"Fear Effect 2 - Retro Helix (E) (Disc 1) (En,Fr,De).chd" & @CRLF & _
"Ren & Stimpy Show - Buckeroo$! (U).sfc" & @CRLF & _
"PGA European Tour Golf (E) [Beta B.29] (En,De).z64" & @CRLF & _
"007 - The World Is Not Enough (U) [Beta 21].z64" & @CRLF & _
"007 - The World Is Not Enough (U) [Beta 2.00].z64" & @CRLF & _
"Pokemon Yellow (UE) [C].gb" & @CRLF & _
"Shadowgate 64 - Trials of the Four Towers (U) [Beta] (En,Es).z64" & @CRLF & _
"Mario Kart Wii (U) (En,Fr,Es) [LOSSY].wbfs" & @CRLF & _
"Shadowgate (J) [Beta 1988-11].nes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")