import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(DEFINE)(?'word'(?:[a-zA-Z0-9!?'\"&\\.,+@%~$]|(?<! )-(?! ))+)(?'words'(?&word)(?: (?&word))*?)(?'nothe'(?<!, (?i:a))(?<!, (?i:the|les)))(?'ver_prefix'Rev|Proto|Alpha|Beta))(?'title'(?&words)(?¬he))(?'subtitle' - (?&words))*?(?'upd' (?:Update|DLC - (?&words)))?(?'region' \\((?:(?:A|As|B|C|Ch|Nl|E|F|G|Gr|Hk|I|J|K|No|R|S|Sw|U|Uk|Tw|W))+\\))?(?'version' \\[(?:(?:(?&ver_prefix) )?(?:(?'_ver'[\\da-zA-Z]+)(?:\\.(?&_ver))+|\\d\\d\\d\\d-\\d\\d(?:-\\d\\d(?:T\\d+)?)?)|(?&ver_prefix)( (?:[A-Z]|\\d+|early))?)\\])?(?'part' \\(Dis(?:c|k) \\d+\\))?(?'language' \\((?'_lang'(?:F-)?(?:Ja|En|Fr|De|Es|It|Nl|Ca|Fi|No|Sv|Da|Zh(?:-Hant|-Hans)?|Pt|Ru|Ko|Pl))(?:,?(?&_lang))*\\))?(?'randomshit'(?: \\[DEMO\\])?(?'lossy' \\[LOSSY\\])?(?: \\[Sample\\])?(?: \\(Promo\\))?(?: \\(Unl\\))?)(?'features' \\[(?'_feat'[a-zA-Z]+)(?:, ?(?&_feat))*\\])?(?'ext'\\.(?:gbc|gb|nsp|xci|(nkit\\.)?rvz|gcz|wbfs|wad|gba|type|cia|3ds|nds|nes|sfc|smc|n64|z64|wux|gg|md|sms|iso|pce|chd))$";
final String string = "Amazing Spider Man (UE).gb\n"
+ "Otto's Ottifanten - Baby Bruno's Nightmare (E) (En,Fr,De,Es).gb\n"
+ "Pokemon Kristall (G).gbc\n"
+ "A Hat in Time DLC - Nyakuza Metro [1.1.0].nsp\n"
+ "Pokemon Card GB2 - GR Dan Sanjou! (J).gbc\n"
+ "Asphalt 9 Legends [1.3.1].nsp\n"
+ "Animal Crossing New Horizons DLC - Special Order Ticket Pocket Camp tie-in campaign.nsp\n"
+ "Pokemon Pinball (E) (En,Fr,De,Es,It) [S,DMG].gbc\n"
+ "Arcade Hits - Moon Patrol & Spy Hunter (UE) [DMG].gbc\n"
+ "Daikatana (U) [Proto 2000-04-19] [DMG].gbc\n"
+ "Hang Time Basketball (E) (Unl).gbc\n"
+ "Pokemon Green (J) [1.0] (F-En).gb\n"
+ "LSDJ [9.2.L].gb\n"
+ "Keep Talking and Nobody Explodes Update [1.2.0].nsp\n"
+ "Sonic Mania Plus [1.0.4] (En,Ja,Fr,De,Es,It,Zh).xci\n"
+ "Spelunky [1.22.2a].nsp\n"
+ "Chrono Cross (U) (Disc 1).chd\n"
+ "Chrono Cross (U) (Disc 2).chd\n"
+ "Fear Effect 2 - Retro Helix (E) (Disc 1) (En,Fr,De).chd\n"
+ "Ren & Stimpy Show - Buckeroo$! (U).sfc\n"
+ "PGA European Tour Golf (E) [Beta B.29] (En,De).z64\n"
+ "007 - The World Is Not Enough (U) [Beta 21].z64\n"
+ "007 - The World Is Not Enough (U) [Beta 2.00].z64\n"
+ "Pokemon Yellow (UE) [C].gb\n"
+ "Shadowgate 64 - Trials of the Four Towers (U) [Beta] (En,Es).z64\n"
+ "Mario Kart Wii (U) (En,Fr,Es) [LOSSY].wbfs\n"
+ "Shadowgate (J) [Beta 1988-11].nes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}