import re
regex = re.compile(r"^(?=(?:[^ ]*\ ){0,3}[^ ]*$)(?=(?:[^0-9]*[0-9]){16}[^0-9]*$)[0-9- ]+$", flags=re.MULTILINE)
test_str = ("+37379985565\n"
"+37356667787\n"
"+37309987654\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")