re = /^(?=(?:[^ ]*\ ){0,3}[^ ]*$)(?=(?:[^0-9]*[0-9]){16}[^0-9]*$)[0-9- ]+$/m
str = '+37379985565
+37356667787
+37309987654
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end