package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:(?<PREFIX>:[^ ]+) )?(?<COMMAND>[^ ]+) (?<MIDDLE>[^:]*?) ?:(?<TRAILING>.+)$`)
var str = `:Macha!~macha@unaffiliated/macha PRIVMSG #botwar another :Test response`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}