$re = '/^(?:(?<PREFIX>:[^ ]+) )?(?<COMMAND>[^ ]+) (?<MIDDLE>[^:]*?) ?:(?<TRAILING>.+)$/';
$str = ':Macha!~macha@unaffiliated/macha PRIVMSG #botwar another :Test response';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);