re = /(?<=print\().+(?=\))/m
str = 'print("Hello world!")
print("Hello", var1)
negioaunouenrg("what")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end