re = /^[a-z]+[a-z0-9._-]+[a-z]+@+[a-z0-9]+[._-]?+[a-z0-9]+(?:[._-][a-z0-9]{2,})+$/m
str = 'abc@abc-abc
abc@abc-abc.abc
abc@abc-abc.abc.abc
abc@abc-abc.abc-abc.abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end