$re = '/\b(?=\w*a(?<!h.))(?=\w*?ha)\w*/m';
$str = 'hat hail haa hata aha hall chakras matcha chairman ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);