re = /\b(?=\w*a(?<!h.))(?=\w*?ha)\w*/m
str = 'hat hail haa hata aha hall chakras matcha chairman '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end