$re = '/(?:\w+)?\((?:[^()]*|\((?:[^()]*|\([^()]*\))*\))*\)/';
$str = '/par(tir|te|s)|(quitter.maison)|((heure|quand).(rendez-vous|journée))/i';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);