re = /(?:\w+)?\((?:[^()]*|\((?:[^()]*|\([^()]*\))*\))*\)/
str = '/par(tir|te|s)|(quitter.maison)|((heure|quand).(rendez-vous|journée))/i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end