package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)TODO\((.*)\): (.*)$`)
var str = `// TODO(#42): rewrite this in Rust`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}