$re = '/^(.*)TODO\((.*)\): (.*)$/m';
$str = '// TODO(#42): rewrite this in Rust';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);