$re = '/^T(\d+)H-/m';
$str = 'T16H-seg0001.m3u
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);