$re = '/{\s*{.*?__\(\s*("[^"]*"|\'[^\']*\')\s*[,)].*?}\s*}/m';
$str = '{{ __(\'some phrase\') }}
{{ __("some phrase") }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);