re = /{\s*{.*?__\(\s*("[^"]*"|'[^']*')\s*[,)].*?}\s*}/m
str = '{{ __(\'some phrase\') }}
{{ __("some phrase") }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end