using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\bAccessControlRuleName:([^,]+),";
string input = @"FPWR2120_Access, AccessControlRuleName: Guest IPS and Malware Inspect, Prefilter Policy:
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}