package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\bAccessControlRuleName:([^,]+),`)
var str = `FPWR2120_Access, AccessControlRuleName: Guest IPS and Malware Inspect, Prefilter Policy:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}