import re
regex = re.compile(r"(?:\b(?:tlf|mobile?|tel(?:ephone)?)[.:\s]+)?(?:\(\+45\)|\+45)?\s*\d{2}(?:\s?\d{2}){3}(?!\d)", flags=re.MULTILINE)
test_str = ("lkdjkljlkaf tel.: +45 09827374, +45 89895867, some kind of text... \n"
"mobil: +45 20802020, +45 20802001,\n"
"afsdfadsf tlf.: +45 5555 1212 \n"
"tlf: +4567890202Girrafe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")