#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)Message\=\"(?<Message>.+)\s+SID"
Local $sString = "Message="Internal event: Function ldap_search entered." & @CRLF & _
"SID: S-1-5-18" & @CRLF & _
"Source IP: 127.0.0.1:25855" & @CRLF & _
"Operation identifier: 680571" & @CRLF & _
"Data1:" & @CRLF & _
"Data2: 2796807187" & @CRLF & _
"Data3:" & @CRLF & _
"Data4:""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")