package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?ms)Message\=\"(?<Message>.+)\s+SID`)
var str = `Message="Internal event: Function ldap_search entered.
SID: S-1-5-18
Source IP: 127.0.0.1:25855
Operation identifier: 680571
Data1:
Data2: 2796807187
Data3:
Data4:"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}