import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|,)([A-Za-z\\-]+?)(?::[A-Z\\-]+)?=(\".+?\"|\\d+?)(?=,|$)";
final String string = "EXT-X-DATERANGE:ID=\"PreRoll_Ident_Open\",START-DATE=\"2016-12-14T120000.000z\",DURATION=3,X-PlayHeadStart=\"0.000\",X-AdID=\"AA-1QPN49M9H2112\",X-TRANSACTION-VPRN-ID=\"1486060788\",X-TrackingDefault=\"1\",X-TrackingDefaultURI=\"http,//606ca.v.fwmrm.net/ad/l/1?s=g015&n=394953%3B394953&t=1485791181366184015&f=&r=394953&adid=15914070&reid=5469372&arid=0&auid=&cn=defaultImpression&et=i&_cc=15914070,5469372,,,1485791181,1&tpos=0&iw=&uxnw=394953&uxss=sg579054&uxct=4&metr=1031&init=1&vcid2=394953%3A466c5842-0cce-4a16-9f8b-a428e479b875&cr=\"s=0&iw=&uxnw=394953&uxss=sg579054&uxct=4&metr=1031&init=1&vcid2=394953%3A466c5842-0cce-4a16-9f8b-a428e479b875&cr=\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}