#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(.*) @(\d*)(.*)"
Local $sString = "shubanker @17 - Chourasia.mp4"
Local $sSubst = "\2. \1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)