$re = '/(.*) @(\d*)(.*)/im';
$str = 'shubanker @17 - Chourasia.mp4';
$subst = "\2. \1\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;