package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\?\&](?<params>[^=]+)=(?<values>[^&]+)`)
var str = `/v1/customers/1/sites?includeContacts=True&showOnlyPrimarySites=True&pageNumber=1&pageSize=10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}