import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\[G&\\]).+(\\[\\d+\\])\\s*$";
final String string = "[G&]120948103471390857102349871[002] \n"
+ "[A&]512903451029349012390409232[002]\n"
+ "[2&]512903451029349012390409232[002]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}