re = /^(?=\[G&\]).+(\[\d+\])\s*$/m
str = '[G&]120948103471390857102349871[002]
[A&]512903451029349012390409232[002]
[2&]512903451029349012390409232[002]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end