$re = '/\b(?:apple|orange|pear|lemon|Goji berry)\b/i';
$str = 'I will buy an apple to do an applepie!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);