re = /\b(?:apple|orange|pear|lemon|Goji berry)\b/i
str = 'I will buy an apple to do an applepie!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end