#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\.)(?:\.\.)+(?!\.)"
Local $sString = "Yes.. Please go away." & @CRLF & _
"I have the ball.." & @CRLF & _
"In this case....I vote yes." & @CRLF & _
"....." & @CRLF & _
"......" & @CRLF & _
"These strings should not match:......." & @CRLF & _
"" & @CRLF & _
"You said this because…?" & @CRLF & _
"I dream..." & @CRLF & _
"Suppose...oh, wait."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")