$re = '/(?<!\.)(?:\.\.)+(?!\.)/m';
$str = 'Yes.. Please go away.
I have the ball..
In this case....I vote yes.
.....
......
These strings should not match:.......
You said this because…?
I dream...
Suppose...oh, wait.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);