# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'start'\{\n)|((?'line' (?U)(".*")\: (".*")(?-U),?\n))|(?'end'\})/${start:+CASE\n}${line:+ WHEN $4 THEN $5\n}${end:+ ELSE "other"\nEND}/gm;t' <<< "{
\"word1\": \"category1\",
\"word2\": \"category2\",
\"word3\": \"category3\",
\"word4\": \"category4\",
\"word5\": \"category5\",
\"word6\": \"category6\",
\"word7\": \"category7\"
}"