import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'start'\\{\\n)|((?'line' (?U)(\".*\")\\: (\".*\")(?-U),?\\n))|(?'end'\\})";
final String string = "{\n"
+ " \"word1\": \"category1\",\n"
+ " \"word2\": \"category2\",\n"
+ " \"word3\": \"category3\",\n"
+ " \"word4\": \"category4\",\n"
+ " \"word5\": \"category5\",\n"
+ " \"word6\": \"category6\",\n"
+ " \"word7\": \"category7\"\n"
+ "}";
final String subst = "${start:+CASE\\n}${line:+ WHEN $4 THEN $5\\n}${end:+ ELSE \"other\"\\nEND}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}