$re = '/([\d.]+)/';
$str = '4x(3x1.0) -- задано три размера
5x(3x1.5) -- задано три размера
27x1.5 -- задано два размера';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);