re = /([\d.]+)/
str = '4x(3x1.0) -- задано три размера
5x(3x1.5) -- задано три размера
27x1.5 -- задано два размера'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end