#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bYour email:[^\S\n]+([^@\n]+@[\w.,-]+)"
Local $sString = "Your email: Peter @gmail.com Please enter your spouse's email: Mandy@gmail.com'" & @CRLF & _
"Your email: Please enter your spouse's email: Mandy@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")